ArcDroid NOT cutting accurately

I have tried to recalibrate the machine over and over, but it still will NOT cut accurately. My ROUND features always come out a bit OVALED. It’s visible by eye and easily measurable. Probably about 0.050" out of round on a 1-3/8" circle.

Hey Glenn give us a call and we’ll go through some trouble shooting with you


Has anyone got this to cut accurately or is it just a hobby toy? Spent a lot of time “calibrating” and recalibrating, and consistently, runs 5mm off. Even though the “calibration” is good.

My milling machine is more accurate. Arcdroid holes are only .005” within size. I have no issues producing the parts I want with the Droid.

5mm is a lot! I can get as accurate as BobD. Something isn’t right…

1 Like

5 thousandths of an inch, not 5mm.

Ricardo1 said his is 5mm off. I read yours correctly.


If I could get .005" I would be so happy.

I have had better and worse calibrations. Doesn’t matter, always 5mm off running parallel to the droid. Right side of squares are square left side is off.

Outside of cut is clockwise, any type of hole is counterclockwise. You need to set these before you cut. Good consumables, correct cut height, travel speed and amperage are paramount. Check the actual cut height with the torch turned off in a dry run with some feeler gauges or whatever you may have to mimic what your cutter calls for. You may have to tweek that number in the tune settings to get close to what you actually want. Also do some practice holes and play with kerf in the “tune settings”.
Edit…I wrote this before your most recent post. Now I have no other suggestions.

Are you following the calibration instructions exactly and calibrating the stylus first, then torch?
Your torch offset numbers are so small, it looks like you either aren’t switching tools or your torch is somehow in exactly the same position as the stylus.

Can you post photos of your calibration setup and how your torch is mounted?
Check that your calibration triangle is square and straight, calibration relies on that being the case. The nozzle must point straight down at the table, if it’s at an angle you will get inaccurate cuts.

Thank you all for confirming that it is accurate. It was just me being an idiot. Changed where I had the cutter clamped and now it works perfect.

1 Like