G-code file size

I tried to load a design and it said “file too big”. The file size was 722KB. What is the max the AD can load?

1 Like

@twentz not sure what the max file size actually is. However, whether it’s g-code or dxf there are ways around it. Do a search on “file” or “size” and you’ll find other similar questions/postings along with solutions depending on your file type. I attached a previous posting to get you started. Good Luck! :+1:

1 Like


it’s not actually the size it’s the number of lines of code which is limited to about 3800

You are probably using Fusion 360 to generate the code right?
You need to change your “tolerance” setting the default is 0.01mm or 4 1/10ths of a thousandth of an inch which is crazy small. So basically it breaks your curves down into tiny little lines so short that no plasma cutter in the world could cut them (like 1/10th the thickness of a piece of paper)

This artificially bloats the G-code file and makes it hard for the ArcDroid to Parse
you can also turn on “smoothing” if you run into real trouble

If you are loading a .dxf file… same thing …change the tolerance value on the screen.
ArcDroid Is memory limited though for .dxf so if it’s a really complex file with lots of curves…it’s gonna bork.


Ok that helps a lot. Thanks guys!

I hate to ask how do I get to this screen

I found DXF2GCODE to convert my dxf to gcode it has an optimise buttons that trims things up a bit the more I play with it the more I’ll post. Just a heads up my new computer with windows 10 or11 would not let me load this download… I had to use an old laptop to download the file " $500 dollars wasted on a new computer"