Gcode file to large to load?

I load the part and it says to large stopped at line 2400 something and it shows a 3/4 drawn paths?

Hey the same thing happened to me today, I had a total of 13387 lines of code and got the Error loading code at line 6316. So after searching this forum for a fix with no luck. So I went back into Fusion 360 thought i would try an process the part into number of parts which turn out to be 4 in total. Then I went and loaded into arcdroid set the Zero and the main thing is do NOT move the material once the zero is set! Then done a test run on all the 4 cut files everything looked good so went ahead and cut the parts worked perfectly so now i know it doesnt matter how many lines of code just need to process in sections. Im a novice to all this CNC stuff its all just a learning curve atm.


@Reyno great job on the work. @Jlscheele A few other folks had the same troubles with file size. There are multiple postings on how to modify your project to get ArcDroid to read ALL the code and NOT sacrifice cut quality. Looks like @Reyno found another. I had the exact same troubles you did, and have written several posts to share the solution within Fusion 360. Just do a search on “file size” and you will will see a listing of all the contributions. Good luck, and don’t get discouraged!

Thanks guys
I was thinking breaking up cut files but was concerned about finding center again… excellent ideas and love the cat

Hey Guys

In case you didn’t catch it before the secret is to change the “tolerance” setting when making a toolpath. This dictates how small of segments curve’s get broken up into.
Fusion default is 0.01mm which is 0.0004 ich…no plasma table in the world cuts stuff that tiny. So this artificially bloats the files. There is also a setting for turning on “smoothing” which eliminates extra points in a line.


You can easily fill the screen with some pretty complex curves just by making the tolerance Setting bigger.

More then one file without moving your material is also perfectly valid of course :stuck_out_tongue:


thanks that tolerance fix helped a lot

Thanks for that info👍🏻

Assuming you are working in Fusion 360? How about SheetCam? Is there a setting tolerance in that program as well?

1 Like