Read U disk error

I am trying to load files to the controller. After homing and inserting the USB flashdrive into the controller and selecting “load” the controller says “Read U Disk error!”. The flashdrive works fine in a computer. I also noticed if no flashdrive is inserted the same error comes up. I have just unbox the unit and have not cut anything yet. Is there a problem with the flashdrive port? I tried a different flashdrives and got the same results.

Make sure to reformat the USB stick to Fat32 and that it is 16gb. Larger memory sticks cause problems.

Make sure your usb port is clear.
I’d also recommend sticking with a mainstream popular brand. SanDisk, Kingston, ADATA etc. And grab a free GUI Fat32 format tool. I have a bunch of 32 and 64GB sticks that once properly formatted for FAT32 work fine.

EDIT: Restarted a few times and now the files show up. I am not sure what is going on, but I will chalk it up to the flashdrive. Thanks for the help, disregard the below.

I bought another brand new 8gb flashdrive and formatted to Fat32. I put a .dxf and a .nc file on it and plugged it in. Now it says “Loading…” but after a few seconds gives the same “Read U Disk error!”. Am I missing something here?

It is possible that the internal USB connection isn’t seated 100%
Check your screen hasn’t shifted in the housing during shipping (UPS drops stuff!)

If you see a black band beside the knob the internal PCB may have shifted a bit. this can cause the USB to be a smidge unreliable.

To fix it lust loosen the four screws on the back and shift it over (the screws are in slots)
You can also snug up the four screws around the outside end just to make sure everything is well seated