First start problems

Hello all. I bought my Arcdroid last December from Hare and Forbes Machinery House in Sydney Australia, but for various reasons wasn’t able to power it up until recently. First thing i did was update all the software and firmware. I’m having a hard time calibrating. On the #1 rail, I get only p0 points, althought the numbers after p0 do change, but they get an x behind them. On the #2 rail I get p0 to p5, but then the p’s stay at p5 on each consecutive line. Again, the numbers after the p entries change, but after p5 they get an x. It’s only on rail #3 that I get p0 to p16, and no x’s. Needless to say, the calibration comes out as BAD, and I’ve tried multiple times. I also noticed that when I go to the menu called Tension Test, I get a result from B:, it locks properly and tries to jerk back and forth a bit, then gives me a value. But when trying A the arm just moves some distance, stops, and I get an M930 error box. However, when locking the arms, both arms are locked. Can anyone tell me if they get proper sequences of p0 to pwhatever on all the rails? Is there something wrong with the position card on the bottom of my stepper motor (if that what the pcb on the bottom is)? I appreciate any thoughts and tips from people that might help me to check this out.

Problem is solved. It turned out to be a faulty encoder board on the y motor. Andrew kindy supplied a replacement stepper/encoder for me to replace the faulty one. All’s good now.