Inconsistent On Off Switching Razor Cut 45

I am having problems where the pasma cutter fails to either turn off or turn on between cuts. It is inconsistent where if I run the job twice the problem occurs on the job but in different locations and also the same locations. I have checked the Gcode and all the commands are correct. I tried pausing incase it is a cache issue but when I restarted the plasma never turned. The Gcode has 378 commands I was wondering if this is too complex for the Arcdroid. I would be interested to know if anyone else has experienced this and if so how you may have resolved it.

That almost sounds like it could be the set up of the razorcut45.
Do you have the plasma unit set to 2T cutting?
On 4T it treats it like mesh and won’t turn off.

Thanks Jonno, yes I used 2T cutting. It would be easier to solve if it simply never worked. On a one part it worked perfect but this one had a lot less cuts. I am using a 32 gig memory stick I might try using a smaller one as the stick might be causing issues as the one that worked was on a smaller gig stick. I have also re-written the cut file and broken it down but I don’t think that makes much different when you read the Gcode.

I thought the stick shouldn’t matter.
I’ve done complex ones and it’s always worked.
Only issue i’ve had is false probes, but that’s been my mistake and not the droid.
If you wanted, dm the file across, I can check it on my machine. How did you create the gcode?

It is much more likely to be an air supply or wiring issue with the plasma cutter then anything the ArcDroid is doing. The AD has no way to selectively decide which cuts to do an which not.

Double check your wiring is tight and that you have adequate air supply. Also double check the Air solenoid inside your machine. if this is sticking it won’t do a proper quick on/off cycle it needs to do in order to reinitialize the arc. You can test this by increasing the “off delay” in your Tune settings to wait until the air stops flowing between cuts (usually about 10sec) It it restrikes the arc reliably than you likely have a sticky air solenoid.

Also the USB stick does not matter you can actually remove it from the machine after you have loaded a file.


Thanks Jonno, I re-wrote the Gcode file, intersting the new version was 50% bigger. Still had the same issue though. I have read Andrew’s comments below, I had a sneeaky suspicion it might be the plasma cutter, it is brand new and I puchased specifically to leave on the Arcdroid.

Thanks Andrew, I will try what you have suggested. The plasma cutter is brand new so might need a bit of bedding in. I puchased a CNC specific plug in cable, air supply is not an issue I have a pretty high capacity system with 32 mm internal diameter lines and the air going into the machine is 90 PSI, though the hose real is smaller diameter so I will try bypassing this. You have given me a bit to try. BTW the cuts that have worked, wow amazing, followed your ytube clips and set up was easy, almost plug and play.

I did have a pop up screen that said something about beta cutting and contact info so I will update the firmware, I formated a memory stick via the Arcdroid today to do this.

The only real reason I know to check for a sticky Solenoid is one of the plasma’s (new) we got for testing early in development gave me 2 days of grief trying to figure out what was up.
Just turned out that it needed a little lube on the solenoid so it could cycle fast enough for the Arc to restart. This is commanded by the plasma cutters software so it’s not something the ArcDroid has any control over.

You wouldn’t notice in daily hand use as you’re much more likely to set it down and have the air time out before restarting the arc.
But without an off/on cycle of the air it won’t strike an new arc.


That is for the Torch Height Compensation feature.
this is an advanced feature and not needed in 98% of situations. Unless you’re really keen to try it you can ignore the pop up


Ok thanks, I will ignore, I am basic I purchased the Arcdroid and then spend 4 weeks learning Fusion 360 so I can use it before my first try. So super happy that I can now draw and cut what I want want for my car restorations, I also use cardboard templates so the trace was a big driver in my decision to buy.

I think you are right, I will do this maintenance, as this would explain it being intermitent and inconsitent, I was not convinced it was software related.

Hi Jonno,
You take the chocolates, I orignially miss read your reply and thought you were talking about 2T cutting Gcode (which is actually 2D). I went to adjust the power and saw the Razorcut45 has a 2T - 4T button and had a flashback to your reply. As soon as I switched this to 2T the Arcdroid worked faultlessly, classic operator error. I also followed Andrews advise and lubricated the air solinoid which is not a bad thing either. Thanks for your help I am extremely grateful.

1 Like