Arcdroid not firing

Hey everyone first time posting here, first off I love this machine I bought one about 4 months ago and use almost daily, but here’s my relatively new problem the CNC cuts only when it feels like it and it’s unpredictable I hear the arcdroid click but the torch doesn’t always fire and sometimes I’ll let it run and it’ll start cutting 60% of the way through a line, I’m sure this is something going on with my plasma and not the arcdroid but any help would be appreciated and yes the ground is always connected properly and the plasma cuts normally when hand held, thanks in advance!

I had a similar problem. Cutting components with several holes, cut-outs, etc. it would randomly not fire on one or two but fire ok on the rest. Lowering the torch to almost touch the plate cured this problem, but then the shield/nozzle often touched the plate, which caused other problems, sticking etc. My solution (after some trial and error) was to skim down the face of the outer shield to allow the nozzle to the plate, but still have o good gap between the shield and the plate. I’ve had no problems with firing since.
Hope this helps.

1 Like

Magnetic grounds can be a problem not grinding down to good metal and check your air supply my hose real will collapse and cut off my air supply or your plasma may be high frequency you must have low frequency only so far that’s been quick fixes whenever mine does the same things

@LittleHellion

What sort of Plasma cutter are you using?
We had the same problem in development (everlast 52i) and it drove us nuts until we discovered it was the air solenoid Inside the Plasma cutter. It would fire once and then not again or would sometimes kick in half way through a cut.

It has to do with the way it starts the Arc it has to cycle the solenoid to get the the air to turn off/on really quickly. If the solenoid is sticky or dirty sometimes it won’t cycle.

So look into that.

Otherwise its possibly a ground situation like others have mentioned

Cheers
AM

2 Likes

I’m using a propoint pro cut 30 I’ve tried everything I’m now starting to believe it is the arcdroid and not the plasma, I took the air solenoid apart and re greased it and it still behaves the same, I lowered my z to almost 0 no difference, my concern is that it often doesn’t cut on the first cut so it has nothing to do with solenoid timing, it doesn’t fire 9/10 cuts it’s become a chore to use which I hate because I love this machine, again the plasma on its own works like a dream so I don’t know what’s going on but it’s discouraging, it worked excellent for 4 months now I can’t get a basic triangle cut without hitting run 8 times hoping it fires on the next run

I don’t have a magnetic ground, the ground isn’t the issue it would be the easiest problem to solve, and my air supply is fine I even re greased the solenoid, the arcdroid won’t fire on the first cut meaning there’s a signal problem or something and it’s not air, I’m having quite the challenge finding the issue, next plan is to return to the old software see if that returns it to working order

Off the wall suggestion check your wiring from the Droid to your plasma cutter, could be a short or a looce wire. I put in a boat quick connect in the cnc wire so I won’t have to dis and or reconnect my wires.

1 Like

Yeah good idea might start fresh with the wiring maybe my wire taps came loose