Plasma tourch not able to return to height

When homing my unit the head wont torch wont return all the way up unit seems to be too heavy for the unit. As with e stylist on it does or with a little assistance it can. It is about 3.79mm short. I have tried lubing it up no help there.

Your torch/cable set up may be to heavy or impeding motion. Home the Z with nothing on it.

Thanks Bob it homes without a problem with nothing on it
It seems to be once it has the torch on it it has an issue
It comes up with an error and makes a bit of a grinding sound at the top the z reading comes up as 3.47mm then it says the no coms for 5 seconds
I hit reset and try home and it does same against
Is it possible there is a reading or some thing at that top end it lifts it fine just that last 3.47mm issue

What type of plasma cutter and torch are you using?

It’s a Unimig 45 nothing to big I have it attached with an overhead cable support so as not to put extra weight on the arm

I’m pretty sure the operation of the Z axis closely monitors servo motor load in both homing out and locating the work surface. Upward motion is pulling a cable with a screw. Downward is relaxing that cable and gravity + return spring are pretty much the linear force.
I have found it to be most sensitive to weight when homing out. I generally never do this with anything on the head. No torch, sled, or stylus. After that initial homing there really is no need to do it again.
I have also found using a spring or bungee to support the torch/lead weight really doesn’t work that well. Using a pulley and counter weight has better promise and you can really dial it in to make things “weightless”
There may well be accessible settings for the Z performance to be tweaked. What they are or how to do it I have no idea.
I wish you could change the Z jog speed or incremental movement with the knob. I find myself using a dial indicator on the head to see what things are doing when leveling or dealing with wavy stock. 3 variations of the knob motion would be nice.

Hey there

We had an issue with some units struggling to move the Z because of a out of spec Follower nut on the drive. This is most likely your problem.

Send us an email and we’ll set you up with a repair kit.



@Andrew is there a measurement or test to determine if an out of spec Follower Nut is in your machine? Is the problem the nut engagement is too tight? I’d like to determine if my Droid has this affliction……

Hey Bob
If your ArcDroid was purchased between Sept and Nov 2022 and it is struggling to lift the head then it is almost certainly afflicted.

The issue is actually a nut that was too loose! and insufficient lube causing vastly premature wear. Seems to affect about 5% of the ArcDroids produced during this time.

Please send us an email with your details and we’ll send you a repair kit ASAP


1 Like
I'll do that Andrew.  Pretty sure I have an issue although not a severe case of it.  I'll shoot you an email.

Thank you Andrew Email sent tonight
That is customer service plus what a product and a product producer

I have this same problem, I sent you an email too

I have same problem and mine was bout in that same time period. I’ll get an email out to you as well

Just wanted to revisit this thread and give a shout-out to @Andrew I just finished the Z axis nutplate replacement. The kit was well thought out and everything you need to understand and do the job is included. It certainly improved my Z performance.
Two comments on the kit. Instructions were good. The problem with black and white photos is you can barely see the arrows pointing things out. Arrows need to be white.
A tip for where a heatgun is used to loosen loctite on the Z rail screws. A full size soldering gun is slick for,this. Get it hot, wipe the tip, and press it onto the screwhead your removing. Maybe five minutes. Heat goes exactly where you need it and nowhere else. Feel the rail to judge the heat.
After now being completely familiar with the Z workings I wondered something.
Is the function of detecting the work surface affected by the area of the range of motion of the Z?
You could be set up to contact near the bottom of stroke with very little spring pressure or you can set things up and stay much closer to the home position end of things and maintain more spring pressure throughout touching off. Thinking this may relate to some other posts on erratic cutting height issues.

1 Like

I just got my Arcdroid but wonder if I am having the same issue. I didn’t know it was an issue until i tried to calibrate it. I can not lift the pen up high enough to get it on the slide. I can force the probe up and the cable goes slack. In this picture that is as high as the Z axis goes up.

@Brent That does look a bit low. My machine has 11mm gap above the Z slide when it homes out. This is really about the set length of the Z cable. There are two set screws on the slide that secure the bare cable end. You should be able to see 1-2mm of the cable protruding from the end of the slide.
You can also reposition the head itself on the slide. There are different sets of holes for the flathead screws. Won’t affect the home position of the slide itself but affects the working height of the torch.

I have a 5/8 inch gap (16 mm). The torch is not a problem, just the pen.

You can also adjust the Z height by loosening and repositioning the dovetail the holds the head assembly to the arm.