Replacing Control Board

Hi Guys,

I have had to replace the main control board in the Arcdroid as the RJ 45 Data Plug Port was damaged.

I have put the new board in but now the torch wont fire. I can rule out the plasma as this was working fine prior to changing the board and I have even tried a different RJ45 cable.

When I go into the G Code Terminal and type in M3 to activate the torch i can hear the relay on the board click and the light next to it come on. There are some pictures below as well.

I have updated the firmware and the software but still no luck. The machine will run but just not fire the torch. Is there anything else I can check or do?

Arcdroid 4
Arcdroid 3
Arcdroid 1
Arcdroid 2


Did you perhaps plug the connectors back in to the wrong spot?

On the main board “Torch” is the right most Connector but on the output board it is the Left Most

It’s impossible to tell from your Picture but you may have crossed up Torch and AUX 1


1 Like

Hi Andrew,

Thanks for getting back to me. I have rechecked that connection and it is right. Below is a picture showing this with the tester pointing to the cable locations.

I have two of the Arcdroid’s here that the board has been changed on and both are having the same issue with not firing the torch.

I changed one myself and the other was changed by a different person but all the wiring looks to be in the correct place on both.

With this one I have also tested the continuity off the torch cable and this is fine so no damage there.

In the second picture I tested continuity between the black cable torch cable on the main board and then to the output end and it is always present. With the red cable there is no continuity. I would think this is normal as the Arcdroid will need to give the signal to allow this work and complete the circuit to fire the torch.

I then turned the Arcdroid on and tried the same test when I engage the torch and send the M3 code in the G Code terminal. At this stage I would think when the relay clicks and the light in on I should get continuity between the red torch wire cables as this will complete the circuit and fire the torch?

This does not happen so not sure where to look now. My next idea is to take a board out of a working machine and swap it over and eliminate the board as a fault. I just wanted to check if there might be something else to check or something I am doing wrong before I do this.

I have tried different screens and RJ 45 cables so I can rule this out. I know the plasma unit is fine as well.

Are your red wires mixed up?

If the red wire has no connectivity, it’s either swapped or damaged.


The colour of the wire is irrelevant to the torch connection as it is only a relay not polarized
However you should Always have continuity between ends of the wires regardless of relay ON/OFF
So if your red wire is not showing continuity then that’s your problem!

that being said …what’s going on here?
Did you scrape the insulation off the copper…it almost looked like it burned off.

I’m sorry I don’t 100% remember your case but I believe the original reason for replacing main board was due to improper hook up. You may have fried the copper traces on the PCB hence no connection to the red wire

If the red light is on and relay clicks then then ArcDroid is working correctly but you basically have a broken wire between relay and our put.

I have a bunch of the Output PCB’s lying around and I’m happy to send you one to swap it out.
Send me a reminder email and I’ll get one out to you first thing Monday


Hi Andrew,

It was the output PCB. Swapped it out and everything works. Thanks for all the help.