Scale Feature Available

I am having a difficulty, I draw my image in Inkscape using inches, and am using QCad/Cam to create the Gcode. When I load the gcode into the Arcdroid, it seems to be in millimeters, the drawing is huge. I thought there used to be a “Scale” feature where you could scale the drawing after it was loaded in. I can’t seem to find it now. I upgraded software recently in the Arcdroid, did that feature get removed? Thanks for any help.


Hey Tim
Scale is still there in fact if you have the newest version of Simple Trace you can scale and rotate etc the drawing in the regular trace Screen.

If you are importing a .dxf the button is here

If you are in the trace menu press this button.


I am importing gcode. The gcode file is definitive and will set the size of the object, and is not scaleable. That is why the scale option is not available. I did load in a .dxf file and the scale button was there. Thanks for the quick response.


You can scale G-code too!. You need the latest version of Simple trace.
Bring In the G-code…choose trace and the new transform button is there (shown above) this will allow you to scale anything hat shows on the screen


When you create the gcode, does the post processor set the output to G20 (imperial) or G21 (metric)?

Look at the gcode generated. Should be noted in he first few lines.

If it’s showing G21, use a text editor like Notepad and simply change it to G20 and reload to see if it clears things up.

If it’s showing G20 already, then I 'm not certain what may be happening within the ArcDroid’s import routine.

Sorry, I downloaded the latest software, but still don’t see that icon button?
My system firmware says March 6, 2023 and the firmware date is the same.


The latest firmware is May 15, you are not up to date
This is the version with the scale feature, you will need to update both Simple trace and The Arcdroid Firmware.

There-in lies the problem. I cannot seem to update the firmware. When I load the blank micro SD Card with the firmware, the file name does not change from a .bin file to a .cur file type. I have tried numerous times, but still no luck. Thanks for all your help!!

Hey Timmy
Are you extracting the file from the .zip?
And are you using SD card/USB drive less then 32Gb and formatted as FAT32. Those are the only things that really hold up the process.

I reformatted the 8 Gb card again as FAT32, extracted the file using Winzip. It shows up as arcdroid-control-fw.bin and is the only file on the SD card. Is there another way to force the download? I will try again today to get it to download.


That should work fine
Put the card in and power it on that’ll update the system automatically.
Are you able to update Simple trace via the USB?


Still no luck yet on the firmware. I tried changing the file name to a .cur, but no luck.

Does this screen show that the simple trace is updated? Is that the top line?

Thanks for all of the info.


Hey @Timmy

The “System” listing is the main board firmware…yours it up to date! So it did work!
The “Board Firmware” is simple trace…yours is NOT up to date. (Mar 6)

So whip out that USB drive and make with the updaty bits!


I’m sorry, but things have gotten worse. I tried updating the simple trace, but I can’t get anything to boot up now. Seems to be all dead. Powering up and down and nothing shows on the screen. What do I do next?

Give us a call on Monday we’ll walk through some trouble shooting with you.



Check the power outlet voltage