After calibration touch screen not responding

After the calibration (machine acknowledged that the calibration was successful), I was going to do a simple trace test. As I tried to select the trace button, it did not respond.

Has anyone else encountered this issue?

I have went through the troubleshooting sequence that is in the PDF manual.

The empty file on the USB named reset.txt does attempt a screen calibration. However, it requires to click on a small red dot in the top left corner of the display. This is unresponsive.

The only response is in the bottom right of the screen. Options are extremely limited if you can only select options that are in that bottom right corner.

I am hoping that it is a simple reset somehow beyond the obvious of restarting the unit etc.

Try this…

Unplug/plug in/wiggle the ethernet looking cable that connects the pendant to the 'Droid

@BenA -
Not wanting to overlook the obvious, but just to eliminate it from the list…
…Did you hit the home button first after turning the Droid on?

@Jim @bobplewajr

Hey guys! Thanks for chiming in! I have been stumped!!

I won’t be able to try the unplug/wiggle thing till tomorrow ( on the road). However I have overlooked the obvious before! Lol! I will try this.

As far as hitting the home button, I believe I did, but not 100% sure……hopefully this didn’t harm anything if this was overlooked.

The problem now, is pressing the home button on the touch screen is unresponsive :man_shrugging:t2:

If it is requiring the home button to be pushed, I am in a dilemma!! Hopefully it is something simple.

I left a message for @Andrew , but he is a busy fella!! I might just have to be patient.

@Jim @bobplewajr @Andrew

I tried your suggestions. No luck. The arm does not home after powering up.

I should mention that the dial that controls the Z axis does move the carrier up and down, but that is all the action I can get.

I’m sorry to hear that. The only other thing I can think of (and you probably already tried) is to push the reset button right under the knob

If that doesn’t work, try reaching out to Andrew directly. He was great about getting back to me when I had a question or two.

Good luck. I hope you find a solution . This really is a slick little unit, and it seems like Andrew really cares about ArcDroid’s reputation.



I have tried that reset as well.

I am confident that Andrew will get it figured out!

I own a small excavating company, and am fully aware that sometimes machines/equipment/computers etc, can give issue even from brand new!

Thanks for your effort to help!


Hey Ben

Sorry for the delay getting back to you.
I just arrived in Hong Kong after a delayed flight ment I spent an extra day in Korea. So I’m a little behind.

I’m not entirely certain what is wrong with your screen as yet.
Completing the calibration should have nothing to do with screen operation so that is probably just a coincidence.

If you’re able to use the knob and attempt to use the reset.txt then I’ll communications appear to be working fine.

The only thing I can suggest otherwise is to look for any sort of obstruction around the outside of the bezel. We had one a while ago that had a tiny piece of paper stuck at the edge and was causing the display to think somebody had their finger on that corner 100% of the time.

You can also try reset.txt again but use the tip of a pencil to touch the dots rather than your finger.

If you’re unsuccessful please send an email to our main address with description of your troubles and we’ll see about getting you a replacement.


We are up and running!!

It was a small crumb of something in the bottom right hand portion of the screen. When you mentioned that a piece of paper was stuck in a different unit, I looked closely along the edge. Sure enough, I could see the slightest deflection of the touchscreen. At that spot was the small piece of debris. I used a corner of a piece of paper to remove it. Success!!

Thanks for the direction!



Time to rock & roll…!!!


Woot! Now you get to go through the learning curve. Don’t be shy about using this forum!

1 Like

Rock n Rollin is no good.

Better to start Cut n shut’n ! :grinning:

I will need every advantage I can get from the forum!
I’m no stranger to fabricating with the original C.A.D. (Cardboard assist!), but feel like a fish out of water with certain things that have circuit boards in them!!