Anyone having trouble with new firmware and SimpleTrace down loads

Tried 3 times with different sd and usb. This is my screen every time after machine update

Never had this problem before. Cards were formated before download was transfered

Also can’t find and language or pattern up date.

Did you unzip the files, I forgot and had to do it over again.

Yes i did never had a problem before did the upgrade in feb and then in May. Is there something else i forgot. I am almost 70 years old so not like i got a new processer up stairs

Did you format the disk beforehand you may have two downloads on the disk. You may have to email Andrew? for help.

Yes and even swapped the (3rd time) last time to new micro sd and new usb. Formated both just like the first two times…I can’t figure this one out. Going to try one more thing and see if that works.

Well tried all i know to do and download not showing to pattern when loading files.
Any help would be wecomed with open arms.
Thanks in advance
Anthony B

Hey Anthony

Update is same as always just now we have language choices. I assume you are going for the EN version

Make sure you unzip everything on your PC and then copy all of these files onto your USB.

I thought patterns was part of the update. I seen the “load as pattern” was this not part of the update because that’s what is not showing up.


Hey Anthony.
Yes the “Load as Pattern” function is part of the latest update.
Simple Trace is not updated on yours yet though.

I down loaded the simple trace and 3 different times even changed usb sticks made sure it was in fat32. And never could get it to up date. Firmware did but not simple trace. Never had a problem before.

Double check you have the right files on your USB and not Just the “EN” directory
If the main directory on you USB doesn’t look like above then it won’t update

I’m having the same issues using Mac. Everything is correct and double checked and done the same way as last time when it worked. ( may 14 3023).

Ok i opened the “en folder” selected all the files in the folder and put it on the usb after formatting the usb and the Arcdroid worked udated fine . I always just unzipped to the usb stick and it always worked not this time. Good to know thanks Andrew. You might want to make a short video on YouTube for others that might have this problem and be a couple slices short of a loaf as me on this computer stuff.

Is THC in full form on this update or is it still in Beta?

Still in beta. You do get a new feature that compensates torch height by touching off at three places on your work piece and adjusting the cut height.