NEW RELEASE OF SIMPLE TRACE and MAIN CONTROL FIRMWARE

Hey Guys.
New Release of Simple Trace out today as well as some updates to the Control firmware.

One of the highlights a new Auto-Level feature.
image

This helps compensate for tilted or unlevel material, just choose three points on your table or your steel and ArcDroid™ will automatically calculate the tilt and move the Z to compensate as it cuts! No more torch plowing into the plate on the opposite corner you started from.

And for those using the THC feature, don’t worry its still there (just hold down the button to switch back). In fact, we’ve made some big improvements to the algorithm. Torch Height Compensation is still an advanced feature but now its more powerful than ever.

Another great new feature is we’ve managed to configure the internal memory on the ArcDroid™ to store trace files! You can now store and retrieve up to 100 Simple Trace and .dxf files directly from internal memory no more need for the USB drive. No Drive inserted… save to onboard memory, put the USB drive back in…save to USB. It’s as simple as that.

And Lastly…one you’ve ALL been asking for ! ROTATE/SCALE/MIRROR
You can now change the Orientation, scale, and origin of your Trace as well as Flip it

Note: if you want to take advantage of all the features you’ll need to update Both sets of Firmware
** Do not do them at the same time!**

5 Likes

I tried the update, and it hasn’t worked. It deleted the old files, was uploading the new files, and then told me to insert the USB with the updated files on it and press reset. Well that was the usb with the new files on it.
What am I missing?

Simple. Something got corrupted on the update.
Just clean out your USB key and transfer Only the TFT70 directory and contents onto it
Insert and reset it should redo the missing parts of the update.

This is how far I got. Nothing happens.

Sweet, will try that.
Thanks Andrew

I tried to go back a step, and put the previous version on.
Got stuck there too. This time however, I did notice that it mentioned its the font files that were corrupt.

For me, it would appear the TFT folder is the issue.
I just can’t get past it, and I can’t roll it back. So at present I am not able to use my machine.
I don’t know if I should have done firmware first, which i will do tomorrow.

@Inhabor

You need to update Both the Simple trace AND the machine firmware in order to use the new Auto level feature. You probably have not updated your machine control Firmware (micro SD card)

go to settings->tap AD logo 5 times->Version info and it should look like this

@Jonno Hit us up by email and I’ll walk you through the trouble shooting info@arcdroidcnc.com


Greetings,
I am looking at the support page / uploads…
For the firmware update I am seeing 2 different forms of the SD card. I looked at the manual and on YouTube, and I don’t see any videos on updating the Firmware. I am looking at the interface of the Arcdroid were you plug the pendant into, and see the slot for the card, but not sure which [ SD / MSD ] card I need to order from Amazon, to interface into the Arcdroid reader.

Any assistance would be appreciated.
Thx

sigh,

i answered my own question, my apologies.

There is also the official video :stuck_out_tongue_closed_eyes:

3 Likes

Yes, that was the problem. Everything is upgraded now. Everything is there now, but I’m keep getting this message every single time I try to use the machine. Even with the leveling feature turned off. What am I doing wrong. I haven’t been able to cut anything since the upgrade. Thanks Andrew.

1 Like

I just want to give a huge shout out to Andrew and his team. not being able to get the update was getting frustrating. But some logical problem solving by Andrew and his team, and i’m up and running again.
Thanks again guys

4 Likes

I am experiencing the same issue. Immediately after installing the latest update I started getting this error. Arcdroid told me it was likely due to a failed probe and to check the function of the probe switch at the base of the zaxis cable. My switch seemed fine. I’m skeptical this is the issue as it started malfunctioning immediately after I updated my arcdroid.

@34787Bob @Inhabor
We’re looking into it… it may be an odd conflict with the probe offset settings.
We haven’t been able to repeat the error but one of our other clients with similar issue Reset his machine to factory default values and recalibrated and claims it’s behaving now.

I’m not entirely sure why that may have worked but its worth a try.

Settings->Machine Settings->Scroll all the way down-> “Reset to defaults”
Make sure is saves on the way out

If we do find a definitive answer we’ll let you know ASAP

Cheers
AM

Andrew, thanks. Is there somewhere I can download the previous version of the firmware? I neglected to save a copy of the previous firmware. I’d rather simply revert to the previous version and avoid experimentation, while you sort this out.

Previous version is also available on our website for this exact reason :stuck_out_tongue_closed_eyes:
Same page just click on “previous version”

Thanks Andrew. I will try that tomorrow.

Thanks Andrew, I only see the previous version of the simple trace software and not the firmware. Is there somewhere I can download the firmware? See the attached screen capture, there doesn’t seem to be a download link for the firmware, just for simple trace.