X2 Firmware Fail

I am trying to set up the x2 extension but i have installed the updated firmware and the X2 button is not appearing on simpletrace screen. I have tried redownloading and installing updates multiple times to no avail and when i check the version on screen it is the up to date version, any help wold be much appreciated

You have to have both the newest firmware and newest Simple Trace installed. Can you toggle any of the selections, THC, Auto Level?

I installed both new firmware and simple trace but I’m not getting the X2 option on screen I can still toggle all others option

Had you loaded the previous Simple Trace version? I think that was when X2 was introduced and the latest was bug fix for torch disable.

@Andrew can you chime in on this please? Just started to mess with the X2 that arrived two weeks ago. I did the two updates tonight without problems. Like @DonalC I had no X2 icon box showing. Found no way of turning the function on in other screens. Didn’t have the X2 table connected. Figured it needed that connected and the X2 window would appear. Powered down the droid. Screwed the power connector to the Aux 1 & Aux 2 screws. Plugged the power cable in and the usb cable in. Turned the Droid on and nothing but a black screen. Shut it right off, tried again, nothing but blackness. Powered down, disconnected the X2 power plug and usb cable. Turned on droid, black screen. Shut off and removed the X2 power board from the Aux terminals. Now the droid powers up ok. So do I have a problem with the X2 power board? Should the X2 icon window be present without the X2 connected?

@Andrew I have had the same experience as @BobD no X2 button appears and when i connect the X2 board i get a blank screen

@DonalC @BobD I am having the same troubles. I emailed Andrew and his team back a forth a number of times troubleshooting last night. He had me take a few continuity tests, and then made a suggestion to snip off the AUX 1 negative terminal. This allowed the touchscreen to boot up. (PLEASE DO NOT DO THIS ON MY WORD ALONE) The next thing we attempted to tackle was why the X2 button was not showing. The last thing I sent him was a pic of the version screen showing the latest updates. I will keep you guys posted when Andrew replies.

@Andrew Once again I appreciate your customer service and dedication to problem solving.

Thanks :+1:

@BobD @DonalC

The X2 button will only show when the X2 is plugged in and working

However we are having some edge cases with the failure to power up thing happening.
Still trying to work out what’s happening there. Bob has been handy with providing some data that has helped narrow it down

So my advice at the moment is to no connect the X2 if your are having troubles . But if you could please send us an email and I have a couple debug steps we can go through

Like I say I’m not entirely sure whats up but we’ll get it solved shortly


Hi Andrew

I am having the issue with my screen being blank once I connect the X2 and the X2 button doesn’t appear on screen even after updated firmware and simple trace. I have tried installing old firmware and simple trace then reinstalling newest versions put still having no success


Thank I’m aware just not sure what the issue is yet
Please disconnect the X2 (the button will NOT show ) if it is blanking your screen. this means ther may be an internal short and could be causing damage.

Bear with us while we figure this out. Pleas also send me an Email to arcdroidcnc@gmail.com and we’ll work through a couple steps

Sent Andrew an email concerning this problem.

Do you think it is wise not to hook up new X2’s until this is sorted out? I just received mine before Christmas and have it ready to go, but don’t want to create an issue with my Arcdroid.

If you only connect the power board to the aux terminals pay attention to the screen when turning on. If it doesn’t immediately start booting up and the screen is black, Shut It Off. I had no damage from doing this. If it passes that test you should be ok.

My screen only went black when the X2 board was connected, when I removed it from the Aux terminals the ArcDroid turned on fine and I did some tests cuts which were fine

So my problem with failing to boot up with the X2 power board connected to the Aux terminals has been resolved. The Aux 1 terminal connections inside the Droid were reversed. Simple polarity swap to cure.
Now everything works as it should. With X2 fully connected, Droid powers up, get a red led on the X2 power board, and X2 icon on the screen.
Thanks to Andrew for assisting with troubleshooting. He was right on it after receiving my email.

Had the exact same issue/fix as well. @BobD do you use AmpMechanic’s THC on your ArcDroid? Just curious if the X2 can work in conjunction with the THC.
The THC uses both terminals on AUX 2 and the X2 shares the ground on AUX 2 so I don’t see why both wouldn’t work. I asked Andrew and he wasn’t certain.

@Amp_Mechanic_JB do you have any thoughts on using THC with The X2?

@bobplewajr I don’t use THC. Really haven’t had the need. Have been using the autolevel. Wondering how that works with the X2? Do you touch off each work panel or do you touch off on one end of the expanded area, then the middle, then shift the droid and make the 3rd touchoff?
It’ll be awhile before I actually set up and run the X2 system. Not sure if I want to use it as a permanent setup. Not that keen on not having the droid socked down. The X2 carriage basically is just sitting on its rails with one lock on one front corner. I dunno, gotta think about how I want to use it.
My current setup works really well for what I do in my home shop. I think the. X2 will be a portable setup.

I wouldn’t think there would be an issue using THC with X2. But in the field, new stuff does come up. I guess we’ll know for sure as people start using it.

I don’t have the X2 and haven’t even updated my firmware since before all the new languages were added. (I can’t even remember what version) But all has been working well for the few cuts I’ve done in the last months. Once I get to a firmware version where everything I need works consistently, I usually don’t update. Unless there some other function added that I need or a bug fix for something that I find. I’d rather have the consistency of the machine working when I do need a part quickly.

I’ve been doing more CNC mill stuff since the summer so, I’m not up on the current ArcDroid stuff.

Thanks for your input @BobD and @Amp_Mechanic_JB. Good luck on your projects. :+1: